Qlik sense unable to login database throwing SqlState: 37000, ErrorCode: 4060
Error:
The login failed.","qLineEnd":"\r\n","qLine":"ODBC CONNECT TO ***","qErrorDataCode":"EDC_ERROR","qMessage":{"qMessageCode":11043,"qMessageParameters":["SQL##f - SqlState: 37000, ErrorCode: 4060, ErrorMsg: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Cannot open database \"START\" requested by the login. The login failed."]}},{"qErrorString":"Connector connect error: SQL##f - SqlState: IM002, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"
Environment
Qlik Sense Enterprise on Windows
Resolution
This is caused by orphaned users in the SQL Server, which occur when a database user is based on a login in the
master
database, but the login no longer exists in
master
. Source:
Troubleshoot orphaned users (SQL Server)
Resolve the issue as mentioned in
Resolve an Orphaned User
in the Microsoft documentation:
Resolve an Orphaned User
.